Linux lua及依赖库安装

lua5.2暂时不使用,使用lua5.1+luarocks

  1. 看readline软件包是否安装(dpkg -l grep -i 软件名)
  2. 是否安装ncurses安装包(ncurses安装包 )
  3. 是否安装libncurses5-dev 或libncursesw5-dev软件包(apt-get install libncurses5-dev)

ncurses-5.9.tar.gz

$ ./configure
$ make
$ sudo make install

readline-6.3.tar.gz

$ ./configure
$ make
$ sudo make install
$ sudo ldconfig

lua-5.2.3.tar.gz

$ sudo apt-get install libreadline6-dev
$ sudo apt-get install libreadline6-dbg
$ make linux
$ OK

lua-cjson

$ vim Makefile
LUA_VERSION = 5.2    
$ make
$ sudo make install

lua rocks

luarocks会自动安装lua版本,现在版本为5.1,如果版本不一致,会导致找不到安装包,建议使用手动方式安装需要的包;

如果使用luarocks管理包,不要单独安装lua,或者必须保证版本一致为5.1

$ sudo apt-get install luarocks
$ sudo luarocks install luasocket
$ luarocks list
$ sudo luarocks install lua-cjson
$ luarocks search **

糖果

糖果
LUA教程

如果不小心安装错 SQL Server 为 Evaluation 的版本,要小心当超过 180 天之后,系统就会无法正常使用了 这几天遇到一个蛮特别的案例,原本收到的问题是 “维护计划” 忽然无法使用,即便是里面没有任何的Task,都无法顺利地执行。但从对方所提供的错误消...… Continue reading

PLUM NIZ静电容键盘怎么样?

Published on September 25, 2020

程序员如何选择合适的机械键盘

Published on September 18, 2020